Миграция с Exchange 2010 на 2019. Часть 7. Предварительные требования и план миграции с Exchange 2010 на 2016

В прошлой публикации мы завершили установку и настройку Exchange 2010. Теперь у нас есть исходная тестовая среда, которую мы возьмем за основу. Теперь нам необходимо подготовить наш план миграции с Exchange 2010 на 2016.

Напомню, что мы не можем мигрировать с Exchange 2010 на Exchange 2019 напрямую. В нашем случае мы будем выполнять миграцию через Exchange 2016.

Весь план миграции с Exchange 2010 на 2016 можно разбить на два большим блока:

  1. Анализ и выполнение предварительных требований к инфраструктуре в целом.
  2. Непосредственное выполнение шагов миграции Exchange 2010 на 2016.

Предварительные требования к инфраструктуре для миграции на Exchange 2016

Полный перечень предварительных требований для установки Exchange 2016 приведен в документации на сайте Microsoft. Ниже мы поговорим про основные моменты.

Сосуществование с предыдущими версиями Exchange

Exchange 2016 может совместно работать со следующими версиями Exchange:

  1. Exchange 2010 SP3 Update Rollup 11 или новее.
  2. Exchange 2013 Cumulative Update 10 или новее.
  3. Смешанный сценарий с Exchange 2010 и Exchange 2013 при выполнении требований к версиям из пунктов выше.

Требование к Active Directory

Для корректной работы Exchange 2016 контроллеры домена должны работать под управлением одной из следующих операционных систем:

  1. Windows Server 2019 Standard или Datacenter.
  2. Windows Server 2016 Standard или Datacenter.
  3. Windows Server 2012 R2 Standard или Datacenter.
  4. Windows Server 2012 Standard или Datacenter.
  5. Windows Server 2008 R2 Standard или Enterprise.
  6. Windows Server 2008 R2 Datacenter RTM или новее.

Функциональный уровень леса – Windows Server 2008 R2 или выше.

Требования к аппаратным ресурсам

Требования к аппаратным ресурсам очень сильно зависят от планируемой нагрузки на сервера Exchange 2016. Более подробно про требования к каждому из компонентов сервера можно почитать вот тут.

Требования к операционной системе

Для работы Exchange 2016 требуется одна из следующих операционных систем:

  1. Windows Server 2016 Standard или Datacenter (требуется Exchange Server 2016 CU3 или новее).
  2. Windows Server 2012 R2 Standard или Datacenter.
  3. Windows Server 2012 Standard или Datacenter.

Поддерживаемые версии клиентских приложений

Exchange 2016 поддерживает следующие версии клиентских приложений:

  1. Microsoft 365 Apps for enterprise.
  2. Outlook 2019.
  3. Outlook 2016.
  4. Outlook 2013.
  5. Outlook 2010 SP2.
  6. Outlook 2016 for Mac.
  7. Outlook for Mac for Office 365.

Краткий итог по предварительным требованиям

Выше при привели требования для Exchange 2016 к сосуществованию с предыдущими версиями Exchange, требования к Active Directory, программные и аппаратные требования непосредственно для самих серверов с Exchange 2016, а также требования к версиям клиентских приложений.

Наша текущая тестовая инфраструктура удовлетворяем всем требованиям выше, за исключением одного – версия Exchange Sever 2010 у нас SP1, а нам нужна минимум SP3 UR11. Будем обновляться.

Последовательность действий для миграции с Exchange 2010 на 2016

После того, как мы поговорили про предварительные требования перейдем к обсуждению плана миграции. Наш план миграции с Exchange 2010 на 2016 будет включать в себя следующие шаги:

  1. Обновление Exchange 2010 SP1 до последней актуальной версии.
  2. Подготовка тестовых почтовых ящиков, групп рассылки и адресных книг для процесса миграции.
  3. Подготовка серверов для Exchange 2016.
  4. Установка Exchange Server 2016 на необходимые сервера.
  5. Выполнение первоначальной настройки серверов с Exchange 2016.
  6. Переключение HTTP/HTTPS и SMTP траффика на сервера Exchange 2016.
  7. Миграция почтовых ящиков, групп рассылки и адресных книг на Exchange 2016.
  8. Завершение миграции на Exchange 2016 и вывод серверов Exchange 2010 из эксплуатации.

Заключение

В предыдущей публикации цикла статей про миграцию с Exchange 2010 на Exchange 2019 за завершили подготовку, установку и настройку исходной инфраструктуры с Exchange 2010. В этой статье мы поговорили про предварительные требования для начала миграции с Exchange 2010 на Exchange 2016. В нашем случае предварительно необходимо обновить Exchange 2010 до последней актуальной версии.

Затем мы поговорили про перечень шагов, который нам необходимо выполнить для миграции c Exchange 2010 на Exchange 2016.

В следующей публикации мы займемся выполнением предварительных требований – обновлением Exchange 2010 до последней актуальной версии.

Добавить комментарий

Ваш адрес email не будет опубликован.